Unabale to set statement_mem

5376 viewscluster database
0
Anees (anonymous)

greenplum version : 5.0
OS: Red Hat release 6.8

I am trying to set new values for max_statement_mem and statement_mem but unable to change values.

I use the following commands to setup new values
gpconfig -c max_statement_mem -v 6144MB
gpconfig -c statement_mem -v 4096MB

But the gpstart process hangs and results the following exceptions. When I revert them to the old values on all segments/nodes and master node gpdb comes up successfully. I have tried many options but no luck. Can any body let me know why I am unable to set new values for above mentioned two parameters.

2017-10-27 14:20:52.876065 GMT,,,p25532,th255870752,,,,0,,,seg-1,,,,,”FATAL”,”XX000″,”Invalid input for statement_mem. Must be less than max_statement_mem (2048000 kB). (cdbvars.c:1390)”,,,,,,,,”gpvars_assign_statement_mem”,”cdbvars.c”,1390,1 0x94d97b postgres errstart + 0x1db
2 0x94f6f4 postgres elog_finish + 0xb4
3 0xa8fa58 postgres (cdbvars.c:1390)
4 0x9711bd postgres set_config_option + 0xc0d
5 0x977034 postgres ProcessConfigFile + 0x304
6 0x9773ce postgres SelectConfigFiles + 0x8e
7 0x7cc8b6 postgres PostmasterMain (postmaster.c:1113)
8 0x705957 postgres main (main.c:206)
9 0x33ca61ed1d libc.so.6 __libc_start_main + 0xfd
10 0x4c7039 postgres + 0x4c7039

Write your answer..